DEVFS(5) BSD File Formats Manual DEVFS(5)NAMEdevfs — device file system
SYNOPSISdevfs /dev devfs rw 0 0
The device file system, or devfs, provides access to kernel's device
namespace in the global file system namespace. The conventional mount
point is /dev.
The file system includes several directories, links, symbolic links and
devices, some of which can also be written. In a chroot'ed environment,
devfs can be used to create a new /dev mount point.
The mknod(8) tool can be used to recover deleted device entries under
/dev The normal devfs mount point.
To mount a devfs volume located on /mychroot/dev:
mount -tdevfs devfs /mychroot/dev
SEE ALSOdevfs(8), mount(8)HISTORY
The devfs file system first appeared in FreeBSD 2.0. It became the pre‐
ferred method for accessing devices in FreeBSD 5.0 and the only method in
FreeBSD 6.0. The devfs manual page first appeared in FreeBSD 2.2.
The devfs manual page was written by Mike Pritchard ⟨mpp@FreeBSD.org⟩.
BSD May 30, 2010 BSD