DEVICE.HINTS(5) BSD File Formats Manual DEVICE.HINTS(5)NAMEdevice.hints — device resource hints
The device.hints file is read in by the boot loader(8) when the system is
about to start, and its contents are passed to the kernel. It contains
various variables to control the boot behavior of the kernel. These
variables are typically “device hints”.
The file contains one variable per line. Lines starting with the ‘#’
character are comments and are ignored by the boot loader.
After the file is read by the boot loader, you may examine the variables
with the show command, and may add a new variable, modify an existing
one, or delete a variable with the set and unset commands of the boot
loader (see loader(8)).
After the system has started, you can dump these variables with the
Device hint variables are used by device drivers to set up the device.
They are most often used by ISA device drivers to specify where the
driver will probe for the relevant devices, and what resources it will
attempt to use.
A device hint line looks like:
where driver is the name of a device driver, unit is the unit number, and
keyword is the keyword of the hint. The keyword may be:
at specifies a bus to which the device is attached.
port specifies the start address of I/O ports to be used by
portsize specifies the number of ports used by the device.
irq is the interrupt line number to be used.
drq is the DMA channel number.
maddr specifies the physical memory address used by the device.
msize specifies the physical memory size used by the device.
flags sets various flag bits for the device.
disabled can be set to "1" to disable the device.
A device driver may require one or more hint lines with these keywords,
and may accept other keywords not listed here. Consult individual device
drivers' manual pages for available keywords and their possible values.
/boot/device.hints Device resource hints file.
/sys/ARCH/conf/GENERIC.hints Sample resource hints for the GENERIC ker‐
/sys/ARCH/conf/NOTES Notes on the kernel configuration file and
device resource hints.
The following example sets up resources for the sio(4) driver on the ISA
The following example disables the ACPI driver:
SEE ALSOkenv(1), loader.conf(5), loader(8)HISTORY
The device.hints file first appeared in FreeBSD 5.0.
BSD October 7, 2001 BSD