DRTEST(8) BSD System Manager's Manual DRTEST(8)NAMEdrtest — standalone disk test program
Drtest is a standalone program used to read a disk track by track. It
was primarily intended as a test program for new standalone drivers, but
has shown useful in other contexts as well, such as verifying disks and
running speed tests. For example, when a disk has been formatted (by
format(8)), you can check that hard errors has been taken care of by run‐
ning drtest. No hard errors should be found, but in many cases quite a
few soft ECC errors will be reported.
While drtest is running, the cylinder number is printed on the console
for every 10th cylinder read.
A sample run of drtest is shown below. In this example (using a 750),
drtest is loaded from the root file system; usually it will be loaded
from the machine's console storage device. Boldface means user input.
As usual, ``#'' and ``@'' may be used to edit input.
Test program for stand-alone up and hp driver
Debugging level (1=bse, 2=ecc, 3=bse+ecc)?
Enter disk name [type(adapter,unit), e.g. hp(1,3)]? hp(0,0)
Device data: #cylinders=1024, #tracks=16, #sectors=32
Testing hp(0,0), chunk size is 16384 bytes.
(chunk size is the number of bytes read per disk access)
Start ...Make sure hp(0,0) is online
(errors are reported as they occur)
(...program restarts to allow checking other disks)
(...to abort halt machine with ^P)
The diagnostics are intended to be self explanatory. Note, however, that
the device number in the diagnostic messages is identified as typeX
instead of type(a,u) where X = a*8+u, e.g., hp(1,3) becomes hp11.
SEE ALSOformat(8), bad144(8)AUTHOR
The drtest command appeared in 4.2BSD.
4.2 Berkeley Distribution June 5, 1993 4.2 Berkeley Distribution