extattr man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

EXTATTR(9)		 BSD Kernel Developer's Manual		    EXTATTR(9)

NAME
     extattr — virtual file system named extended attributes

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>
     #include <sys/extattr.h>

DESCRIPTION
     Named extended attributes allow additional meta-data to be associated
     with vnodes representing files and directories.  The semantics of this
     additional data is that of a "name=value" pair, where a name may be
     defined or undefined, and if defined, associated with zero or more bytes
     of arbitrary binary data.

     Reads of extended attribute data may return specific contiguous regions
     of the meta-data, in the style of VOP_READ(9), but writes will replace
     the entire current "value" associated with a given name.  As there are a
     plethora of file systems with differing extended attributes, availability
     and functionality of these functions may be limited, and they should be
     used with awareness of the underlying semantics of the supporting file
     system.  Authorization schemes for extended attribute data may also vary
     by file system, as well as maximum attribute size, and whether or not any
     or specific new attributes may be defined.

     Extended attributes are named using a null-terminated character string.
     Depending on underlying file system semantics, this name may or may not
     be case-sensitive.	 Appropriate vnode extended attribute calls are:
     VOP_GETEXTATTR(9) and VOP_SETEXTATTR(9).

SEE ALSO
     VFS(9), VOP_GETEXTATTR(9), VOP_SETEXTATTR(9)

AUTHORS
     This manual page was written by Robert Watson.

BSD				  May 8, 2010				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net