fd man page on OpenBSD

Man page or keyword search:  
man Server   11362 pages
apropos Keyword Search (all sections)
Output format
OpenBSD logo
[printable version]

FD(4)			  OpenBSD Programmer's Manual			 FD(4)

NAME
     fd, stdin, stdout, stderr - file descriptor files

DESCRIPTION
     The files /dev/fd/0 through /dev/fd/# refer to file descriptors which can
     be accessed through the file system.  If the file descriptor is open and
     the mode the file is being opened with is a subset of the mode of the
     existing descriptor, the call:

	   fd = open("/dev/fd/0", mode);

     and the call:

	   fd = fcntl(0, F_DUPFD, 0);

     are equivalent.

     Opening the files /dev/stdin, /dev/stdout, and /dev/stderr is equivalent
     to the following calls:

	   fd = fcntl(STDIN_FILENO,  F_DUPFD, 0);
	   fd = fcntl(STDOUT_FILENO, F_DUPFD, 0);
	   fd = fcntl(STDERR_FILENO, F_DUPFD, 0);

     Flags to the open(2) call other than O_RDONLY, O_WRONLY, and O_RDWR are
     ignored.

     These devices may not be opened by processes which are tainted as a
     result of setuid or setgid behaviours, as documented in issetugid(2).  In
     those cases, an error return will occur with errno set to EPERM.

FILES
     /dev/fd/#
     /dev/stdin
     /dev/stdout
     /dev/stderr

SEE ALSO
     tty(4)

OpenBSD 4.9			 May 31, 2007			   OpenBSD 4.9
[top]

List of man pages available for OpenBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net