fubyte man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

FETCH(9)		 BSD Kernel Developer's Manual		      FETCH(9)

NAME
     fetch, fubyte, fusword, fuword — fetch data from user-space

SYNOPSIS
     #include <sys/types.h>
     #include <sys/time.h>
     #include <sys/systm.h>
     #include <sys/resourcevar.h>

     int
     fubyte(const void *base);

     int
     fusword(void *base);

     long
     fuword(const void *base);

DESCRIPTION
     The fetch functions are designed to copy small amounts of data from user-
     space.

     The fetch routines provide the following functionality:

     fubyte()	Fetches a byte of data from the user-space address base.

     fusword()	Fetches a short word of data from the user-space address base.

     fuword()	Fetches a word of data from the user-space address base.

RETURN VALUES
     The fetch functions return the data fetched or -1 on failure.

SEE ALSO
     copy(9), store(9)

BSD				March 14, 2010				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net