GLABEL(8) BSD System Manager's Manual GLABEL(8)NAMEglabel — disk labelization control utility
SYNOPSISglabel create [-v] name dev
glabel destroy [-fv] name ...
glabel label [-v] name dev
glabel stop [-fv] name ...
glabel clear [-v] dev ...
glabel dump dev ...
The glabel utility is used for GEOM provider labelization. A label can
be set up on a GEOM provider in two ways: “manual” or “automatic”. When
using the “manual” method, no metadata are stored on the devices, so a
label has to be configured by hand every time it is needed. The
“automatic” method uses on-disk metadata to store the label and detect it
automatically in the future.
This class also provides volume label detection for file systems. Those
labels cannot be set with glabel, but must be set with the appropriate
file system utility, e.g. for UFS the file system label is set with
tunefs(8). Currently supported file systems are:
· UFS1 volume names (directory /dev/ufs/).
· UFS2 volume names (directory /dev/ufs/).
· UFS1 file system IDs (directory /dev/ufsid/).
· UFS2 file system IDs (directory /dev/ufsid/).
· MSDOSFS (FAT12, FAT16, FAT32) (directory /dev/msdosfs/).
· CD ISO9660 (directory /dev/iso9660/).
· EXT2FS (directory /dev/ext2fs/).
· REISERFS (directory /dev/reiserfs/).
· NTFS (directory /dev/ntfs/).
Support for partition metadata is implemented for:
· GPT labels (directory /dev/gpt/).
· GPT UUIDs (directory /dev/gptid/).
Generic labels are created in the directory /dev/label/.
The first argument to glabel indicates an action to be performed:
create Create temporary label name for the given provider. This is the
“manual” method. The kernel module geom_label.ko will be loaded
if it is not loaded already.
label Set up a label name for the given provider. This is the
“automatic” method, where metadata is stored in a provider's
last sector. The kernel module geom_label.ko will be loaded if
it is not loaded already.
stop Turn off the given label by its name. This command does not
touch on-disk metadata!
destroy Same as stop.
clear Clear metadata on the given devices.
dump Dump metadata stored on the given devices.
list See geom(8).
status See geom(8).
load See geom(8).
unload See geom(8).
-f Force the removal of the specified labels.
-v Be more verbose.
The following sysctl(8) variables can be used to control the behavior of
the LABEL GEOM class. The default value is shown next to each variable.
Debug level of the LABEL GEOM class. This can be set to a number
between 0 and 2 inclusive. If set to 0 minimal debug information
is printed, and if set to 2 the maximum amount of debug informa‐
tion is printed.
Exit status is 0 on success, and 1 if the command fails.
The following example shows how to set up a label for disk “da2”, create
a file system on it, and mount it:
glabel label -v usr /dev/da2
mount /dev/label/usr /usr
glabel stop usr
The next example shows how to set up a label for a UFS file system:
tunefs -L data /dev/da4s1a
mount /dev/ufs/data /mnt/data
SEE ALSOgeom(4), loader.conf(5), geom(8), mount(8), newfs(8), sysctl(8),
The glabel utility appeared in FreeBSD 5.3.
Pawel Jakub Dawidek ⟨pjd@FreeBSD.org⟩
BSD June 13, 2009 BSD