gpt man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

GPT(8)			  BSD System Manager's Manual			GPT(8)

NAME
     gpt — GUID partition table maintenance utility

SYNOPSIS
     gpt [general_options] command [command_options] device ...

DESCRIPTION
     The gpt utility provides the necessary functionality to manipulate GUID
     partition tables (GPTs), but see BUGS below for how and where functional‐
     ity is missing.  GPT partitions are accessed as DragonFly disk slices,
     with same number as GPT partition, 127 slices per disk device are sup‐
     ported.  The basic usage model of the gpt tool follows that of the cvs(1)
     tool.  The general options are described in the following paragraph.  The
     remaining paragraphs describe the individual commands with their options.
     Here we conclude by mentioning that a device is either a special file
     corresponding to a disk-like device or a regular file.  The command is
     applied to each device listed on the command line.

   General Options
     The general options allow the user to change default settings or other‐
     wise change the behaviour that is applicable to all commands.  Not all
     commands use all default settings, so some general options may not have
     an effect on all commands.

     The -p count option allows the user to change the number of partitions
     the GPT can accommodate.  This is used whenever a new GPT is created.  By
     default, the gpt utility will create space for 128 partitions (or 32 sec‐
     tors of 512 bytes).

     The -r option causes the gpt utility to open the device for reading only.
     Currently this option is primarily useful for the show command, but the
     intent is to use it to implement dry-run behaviour.

     The -v option controls the verbosity level.  The level increases with
     every occurrence of this option.  There is no formalized definition of
     the different levels yet.

   Commands
     gpt add [-b number] [-i index] [-s count] [-t type] device ...
	     The add command allows the user to add a new partition to an
	     existing table, the name of the disk slice for the added parti‐
	     tion is printed.  By default, it will create a dfly partition
	     covering the first available block of an unused disk space.  The
	     command-specific options can be used to control this behaviour.

	     The -b number option allows the user to specify the starting
	     (beginning) sector number of the partition.  The minimum sector
	     number is 1, but has to fall inside an unused region of disk
	     space that is covered by the GPT.

	     The -i index option allows the user to specify which (free) entry
	     in the GPT table is to be used for the new partition.  By
	     default, the first free entry is selected.	 Entries start at
	     index 0 representing partition 0 of the GPT.

	     The -s count option allows the user to specify the size of the
	     partition in sectors.  The minimum size is 1.

	     The -t type option allows the user to specify the partition type.
	     The type is given as an UUID, but gpt accepts efi, swap, ufs,
	     hfs, linux, dfly, and windows as aliases for the most commonly
	     used partition types.  ufs is a FreeBSD UFS UUID.	dfly has the
	     alias dragonfly and is a DragonFly disklabel64(5) UUID.  You may
	     also specify any symbolic name in the system uuids(5) files.

     gpt boot device ...
	     The boot command allows the user to create a small boot partition
	     in a freshly created GPT.

	     This command creates a small, 256MB boot partition as partition
	     #0 and hacks in a special ‘slice 1’ in the PMBR which aliases it.
	     The PMBR is further modified to add the necessary boot code.  You
	     can then disklabel GPT partition #0 and mount it, placing the
	     contents of /boot directory within.  You must add a line to
	     loader.conf, like

		   vfs.root.mountfrom="ufs:da1s1a"

	     which point to the actual root mount.

	     Your root partition may be another GPT partition and you may use
	     a 64 bit disklabel within that partition if you desire.

	     The ‘boot0’ boot manager is used, it can be manipulated with the
	     boot0cfg(8) command, ‘packet’ option usually needs to be set.

	     NOTE! A disk setup with the boot command may not be shared with
	     another OS, as it doesn't use a fully standard GPT.

	     WARNING! Some BIOSes may not be able to deal with this hack, your
	     mileage may vary.

     gpt create [-fp] device ...
	     The create command allows the user to create a new (empty) GPT.
	     By default, one cannot create a GPT when the device contains a
	     MBR, however this can be overridden with the -f option.  If the
	     -f option is specified, an existing MBR is destroyed and any par‐
	     titions described by the MBR are lost.

	     The -p option tells gpt to create only the primary table and not
	     the backup table.	This option is only useful for debugging and
	     should not be used otherwise.

     gpt destroy [-r] device ...
	     The destroy command allows the user to destroy an existing, pos‐
	     sibly not empty GPT.

	     The -r option instructs gpt to destroy the table in a way that it
	     can be recovered.

     gpt label [-a] ⟨-f file | -l label⟩ device ...

     gpt label [-b number] [-i index] [-s count] [-t type] ⟨-f file | -l
	     label⟩ device ...
	     The label command allows the user to label any partitions that
	     match the selection.  At least one of the following selection
	     options must be specified.

	     The -a option specifies that all partitions should be labeled.
	     It is mutually exclusive with all other selection options.

	     The -b number option selects the partition that starts at the
	     given block number.

	     The -i index option selects the partition with the given parti‐
	     tion number.  Partition numbers start at 0.

	     The -s count option selects all partitions that have the given
	     size.  This can cause multiple partitions to be removed.

	     The -t type option selects all partitions that have the given
	     type.  The type is given as an UUID or by the aliases that the
	     add command accepts.  This can cause multiple partitions to be
	     removed.

	     The -f file or -l label options specify the new label to be
	     assigned to the selected partitions.  The -f file option is used
	     to read the label from the specified file.	 Only the first line
	     is read from the file and the trailing newline character is
	     stripped.	If the file name is the dash or minus sign (-), the
	     label is read from the standard input.  The -l label option is
	     used to specify the label in the command line.  The label is
	     assumed to be encoded in UTF-8.

     gpt migrate [-fs] device ...
	     The migrate command allows the user to migrate an MBR-based disk
	     partitioning into a GPT-based partitioning.  By default, the MBR
	     is not migrated when it contains partitions of an unknown type.
	     This can be overridden with the -f option.	 Specifying the -f
	     option will cause unknown partitions to be ignored and any data
	     in it to be lost.

	     The -s option prevents migrating BSD disk labels into GPT parti‐
	     tions by creating the GPT equivalent of a slice.

     gpt remove [-a] device ...

     gpt remove [-b number] [-i index] [-s count] [-t type] device ...
	     The remove command allows the user to remove any and all parti‐
	     tions that match the selection.  It uses the same selection
	     options as the label command.  See above for a description of
	     these options.  Partitions are removed by clearing the partition
	     type.  No other information is changed.

     gpt show [-lu] device ...
	     The show command displays the current partitioning on the listed
	     devices and gives an overall view of the disk contents.  With the
	     -l option the GPT partition label will be displayed instead of
	     the GPT partition type.  The option has no effect on non-GPT par‐
	     titions.  With the -u option the GPT partition type is displayed
	     as an UUID instead of in a user friendly form.  The -l option
	     takes precedence over the -u option.

FILES
     /boot/boot0	  The default ‘boot0’ image.

     /etc/defaults/uuids  A list of UUIDs and their symbolic names provided by
			  the OS vendor.

     /etc/uuids		  A list of UUIDs and their symbolic names provided by
			  the system administrator.

EXAMPLES
     To install an empty GPT on ad6:

	   gpt create ad6

     GPT partitions are defined in number of sectors, the sector size is usu‐
     ally 512B, which is assumed in the examples below, it can be found using:

	   gpt -v show ad6

     To add a dummy GPT partition 0:

	   gpt add -i0 -s16 ad6

     You might want to do this to not use slice 0 for data; when GPT is not
     used on a disk, slice 0 is the compatibility slice, which is used for
     “dangerously dedicated” disks.  For GPT slice 0 has no special meaning,
     it is just the first slice on the disk.

     To add a GPT partition of size approx. 100GB:

	   gpt add -s200000000 ad6

     This will be GPT partition 1 as it is the first one free, it will be
     accessible as ad6s1, which is also printed by the command.	 The type will
     be “DragonFly Label64”, it will have to be set up by disklabel64(8).

     To add GPT partition 5 with type “DragonFly HAMMER” using the remaining
     free space:

	   gpt add -i5 -t "DragonFly HAMMER" ad6

     To print the contents of the GPT:

	   gpt show ad6

   Boot Setup
     To setup a disk using GPT for booting, the steps below can be used.  Sys‐
     tem is copied from an already installed disk, e.g. a hard disk or an
     install CD.  This example will setup disk da1 with GPT for booting, using
     the boot command.

     WARNING! Any previous data on disk installed to will be deleted.

	   gpt create -f da1
	   gpt boot da1
	   boot0cfg -s 2 da1
	   disklabel -B -r -w da1s0 auto
	   disklabel -e da1s0	   # add `a: * * 4.2BSD', to add `a' partition
				   #   with fstype `4.2BSD' covering whole slice

	   gpt add da1
	   disklabel64 -r -w da1s1 auto
	   disklabel64 -e da1s1	   # add `b: 4G * swap', to add `b' partition
				   #   with fstype `swap' and size 4GB,
				   # add `a: * * HAMMER', to add `a' partition
				   #   with fstype `HAMMER' covering rest of slice
	   newfs_hammer -L ROOT /dev/da1s1a
	   mount_hammer /dev/da1s1a /mnt

	   newfs /dev/da1s0a
	   mkdir /mnt/boot
	   mount /dev/da1s0a /mnt/boot

	   cpdup / /mnt		   # copy each file system you need, e.g.
	   cpdup /boot /mnt/boot
	   cpdup /var /mnt/var
	   cpdup /var/tmp /mnt/var/tmp
	   cpdup /usr /mnt/usr

	   cd /mnt
	   vi etc/fstab		   # add `/dev/da1s1a / hammer rw',
				   # add `/dev/da1s1b none swap sw',
				   # add `/dev/da1s0a /boot ufs rw 1 1',
				   # delete lines for file systems cpdup'ed above
	   vi boot/loader.conf	   # add `vfs.root.mountfrom="hammer:da1s1a"'
	   cd
	   umount /mnt/boot
	   umount /mnt

COMPATIBILITY
     The GPT that gpt manipulates is part of the EFI standard and is supported
     by many OSs.  GPT uses 64 bits to store number of sectors, this supports
     very large disks.	With the prevalent sector size of 512B this is 8 bil‐
     lion TB.

SEE ALSO
     uuid(3), disklabel64(5), uuids(5), boot0cfg(8), disklabel(8),
     disklabel64(8), fdisk(8), mount(8), newfs(8), newfs_hammer(8), swapon(8)

HISTORY
     The gpt utility appeared in FreeBSD 5.0 for ia64.	It was imported to
     DragonFly 1.9.

BUGS
     The development of the gpt utility is still work in progress.  Many nec‐
     essary features are missing or partially implemented.  In practice this
     means that the manual page, supposed to describe these features, is far‐
     ther removed from being complete or useful.  As such, missing functional‐
     ity is not even documented as missing.  However, it is believed that the
     currently present functionality is reliable and stable enough that this
     tool can be used without bullet-proof footware if one thinks one does not
     make mistakes.

     It is expected that the basic usage model does not change, but it is pos‐
     sible that future versions will not be compatible in the strictest sense
     of the word.  For example, the -p count option may be changed to a com‐
     mand option rather than a generic option.	There are only two commands
     that use it so there is a chance that the natural tendency for people is
     to use it as a command option.  Also, options primarily intended for
     diagnostic or debug purposes may be removed in future versions.

     Another possibility is that the current usage model is accompanied by
     other interfaces to make the tool usable as a back-end.  This all depends
     on demand and thus feedback.

     The migrate command doesn't support DragonFly partition types.

BSD			      September 28, 2009			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net