HCCONTROL(8) BSD System Manager's Manual HCCONTROL(8)NAMEhccontrol — HCI configuration utility
SYNOPSIShccontrol [-hN] [-n HCI_node_name] command [parameters ...]
The hccontrol utility connects to the specified Netgraph node of type HCI
or the first one found if none is specified and attempts to send the
specified command to the HCI Netgraph node or to the associated Bluetooth
device. The hccontrol utility will print results to the standard output
and error messages to the standard error.
The options are as follows:
-h Display usage message and exit.
-N Show Bluetooth addresses as numbers. Normally hccontrol attempts
to resolve Bluetooth addresses, and display them symbolically.
Connect to the specified HCI Netgraph node.
One of the supported commands (see below). The special command
help can be used to obtain the list of all supported commands.
To get more information about a specific command use help
One or more optional space separated command parameters. Many
commands require a remote device address as one of the parame‐
ters. The remote device address can be specified as BD_ADDR or a
name. If a name was specified then the hccontrol utility will
attempt to resolve the name via bt_gethostbyname(3).
The currently supported HCI commands in hccontrol are:
The currently supported node commands in hccontrol are:
The hccontrol utility exits 0 on success, and >0 if an error occurs.
SEE ALSObluetooth(3), netgraph(3), netgraph(4), ng_hci(4), hcseriald(8)AUTHORS
Maksim Yevmenkin ⟨firstname.lastname@example.org⟩
Most likely. Please report if found.
BSD June 14, 2002 BSD