KBDMUX(4) BSD Kernel Interfaces Manual KBDMUX(4)NAMEkbdmux — keyboard multiplexer
The kbdmux keyboard driver provides support for basic keyboard multiplex‐
ing. It is built around the idea of a “super keyboard”. The kbdmux
driver acts as a master keyboard consuming input from all slave keyboards
attached to it.
Slave keyboards can be attached to or detached from the kbdmux keyboard
driver with the kbdcontrol(1) utility.
SEE ALSOkbdcontrol(1), atkbd(4), syscons(4), ukbd(4)CAVEATS
The kbdmux keyboard driver switches all slave keyboards into K_RAW mode.
Thus all slave keyboards attached to the kbdmux keyboard share the same
state. The kbdmux keyboard is logically equivalent to one keyboard with
lots of duplicated keys.
The kbdmux module was implemented in FreeBSD 6.0.
Maksim Yevmenkin ⟨firstname.lastname@example.org⟩
BSD July 12, 2005 BSD