kpreempt_disabled man page on NetBSD

Man page or keyword search:  
man Server   9087 pages
apropos Keyword Search (all sections)
Output format
NetBSD logo
[printable version]

KPREEMPT(9)		 BSD Kernel Developer's Manual		   KPREEMPT(9)

NAME
     kpreempt — control kernel preemption

SYNOPSIS
     #include <sys/systm.h>

     void
     kpreempt_disable(void);

     void
     kpreempt_enable(void);

     bool
     kpreempt_disabled(void);

DESCRIPTION
     These functions are used to control kernel preemption of the calling LWP.

     On architectures where kernel preemption is not supported natively, these
     functions may still be used.

     It should be noted that kernel preemption is also disabled when holding
     the interrupt priority level above IPL_NONE, e.g. using spl(9) or spin‐
     ning mutex(9) calls or holding kernel_lock (indicating that the code is
     not MT safe).

     kpreempt_disable() disables kernel preemption of the calling LWP.	Note
     that disabling kernel preemption can prevent LWPs with higher priorities
     from running.

     kpreempt_enable() enables kernel preemption of the calling LWP, which was
     previously disabled by kpreempt_disable().

     kpreempt_disable() and kpreempt_enable() can be nested.

     kpreempt_disabled() returns true if preemption of the calling LWP is dis‐
     abled.  It is only for diagnostic purpose.

SEE ALSO
     intro(9), mutex(9), spl(9)

BSD			       February 16, 2010			   BSD
[top]
                             _         _         _ 
                            | |       | |       | |     
                            | |       | |       | |     
                         __ | | __ __ | | __ __ | | __  
                         \ \| |/ / \ \| |/ / \ \| |/ /  
                          \ \ / /   \ \ / /   \ \ / /   
                           \   /     \   /     \   /    
                            \_/       \_/       \_/ 
More information is available in HTML format for server NetBSD

List of man pages available for NetBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net