MKEXTUNPACK(8) BSD System Manager's Manual MKEXTUNPACK(8)NAMEmkextunpack — extracts the contents of a multikext (mkext) archive
SYNOPSISmkextunpack [-v] [-d output_directory] mkext_file
The mkextunpack program list the contents of a multikext file,
mkext_file, or unarchives the contents into output_directory (which must
exist). The -v option causes mkextunpack to print the name if each kext
as it finds them.
DIAGNOSTICSmkextunpack exits with a zero status upon success. Upon failure, it
prints an error message and exits with a nonzero status.
The mkext file format doesn't record the original filenames of the kexts,
so mkextunpack has to guess at what they are. It does this by using the
value of the CFBundleExecutable property of the kext's info dictionary.
(Project Builder sets this to the base name of the kext bundle by
default, but the developer can change it.) If that property doesn't
exist, the last component of the CFBundleIdentifier is used. Duplicates
have an incrementing index appended to the name. Kexts that have no exe‐
cutable or CFBundleIdentifier are named “NameUnknown-n.kext”, where n is
Darwin March 29, 2002 Darwin