MLD(4) BSD Kernel Interfaces Manual MLD(4)NAMEmld — Multicast Listener Discovery Protocol
socket(AF_INET6, SOCK_RAW, IPPROTO_ICMPV6);
MLD is a control plane protocol used by IPv6 hosts and routers to propa‐
gate multicast group membership information. Normally this protocol is
not used directly, except by the kernel itself, in response to multicast
membership requests by user applications. Multicast routing protocol
daemons may open a raw socket to directly interact with mld and receive
As of FreeBSD 8.0, MLD version 2 is implemented. This adds support for
Source-Specific Multicast (SSM), whereby applications may communicate to
upstream multicast routers that they are only interested in receiving
multicast streams from particular sources. The retransmission of state-
change reports adds some robustness to the protocol.
This opaque read-only variable exposes the stack-wide MLDv2 pro‐
tocol statistics to netstat(1).
This opaque read-only variable exposes the per-link MLDv2 status
This variable specifies the time threshold, in seconds, for pro‐
cessing Group-and-Source Specific Queries (GSR). As GSR query
processing requires maintaining state on the host, it may cause
memory to be allocated, and is therefore a potential attack point
for Denial-of-Service (DoS). If more than one GSR query is
received within this threshold, it will be dropped, to mitigate
the potential for DoS.
If this variable is non-zero, then MLDv1 membership queries (and
host reports) will be processed by this host, and backwards com‐
patibility will be enabled until the v1 'Older Version Querier
Present' timer expires. This sysctl is normally enabled by
SEE ALSOifmcstat(8), inet(4), multicast(4), netstat(1), sourcefilter(3)HISTORY
The mld manual page appeared in FreeBSD 8.0.
BSD May 27, 2009 BSD