NDISGEN(8) BSD System Manager's Manual NDISGEN(8)NAMEndisgen — generate a FreeBSD driver module from a Windows® NDIS driver
SYNOPSISndisgen [/path/to/INF /path/to/SYS]
The ndisgen script uses the ndiscvt(8) utility and other tools to gener‐
ate a FreeBSD loadable driver module and a static ELF object module from
a Windows® NDIS driver, for use with the ndis(4) compatibility module.
The ndisgen script is interactive and contains its own help section.
Unless the paths to both files are supplied on the command line, the
script will prompt the user for the .INF and .SYS files needed to gener‐
ate the FreeBSD driver module. The script will also prompt for any
firmware or other external files needed.
SEE ALSOld(1), objcopy(1), ndis(4), kldload(8), ndiscvt(8)HISTORY
The ndisgen utility first appeared in FreeBSD 6.0.
The ndisgen utility was written by Bill Paul ⟨firstname.lastname@example.org⟩.
BSD April 24, 2005 BSD