net_getlifaddr man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

NET_GETLIFADDR(9F)					    NET_GETLIFADDR(9F)

NAME
       net_getlifaddr - determine a network address for a given interface

SYNOPSIS
       #include <sys/neti.h>

       int net_getlifaddr(const net_data_t net, const phy_if_t ifp,
	    const net_if_t lif, int const type,
	    struct sockaddr* storage);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI).

PARAMETERS
       net
		  value	  returned   from  a  successful  call	to  net_proto‐
		  col_lookup(9F).

       ifp
		  value returned from a successful call	 to  net_phylookup(9F)
		  or  net_phygetnext(9F),  indicating  which network interface
		  the information should be returned from.

       lif
		  indicates the logical interface  from	 which	to  fetch  the
		  address.

       type
		  indicates what type of address should be returned. See below
		  for more details on this field.

       storage
		  pointer to an area of memory to store the address data.

DESCRIPTION
       The net_getlifaddr() function retrieves	the  address  information  for
       each logical interface. Each call to net_getlifaddr() requires that the
       caller pass a pointer to an  array  of  address	information  types  to
       retrieve, and an accompanying pointer to an array of pointers to struct
       sockaddr structures to which  to	 copy  the  address  information.  See
       net_lifgetnext(9F) for an example on how to use this function.

       Each  member  of	 the  address  type  array should be one of the values
       listed here.

       NA_ADDRESS
		       Return the network address associated with the  logical
		       interface  (lif)	 that belongs to the network interface
		       (ifp).

       NA_PEER
		       Return the address assigned  to	the  remote  host  for
		       point  to  point	 network interfaces for the given net‐
		       work/logical interface.

       NA_BROADCAST
		       Return the broadcast address assigned to the given net‐
		       work/logical interface for network interfaces that sup‐
		       port broadcast packets.

       NA_NETMASK
		       Return the  netmask  associated	with  the  given  net‐
		       work/logical interface for network interfaces that sup‐
		       port broadcast packets.

RETURN VALUES
       The net_getlifaddr() function returns:

       -1
	     The network protocol does not support this function.

       0
	     Successful completion.

       1
	     Unsuccessful.

CONTEXT
       The net_getifaddr() function may be called from user, kernel, or inter‐
       rupt context.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface Stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       net_lifgetnext(9F),   net_phylookup(9F),	  net_phygetnext(9F)net_proto‐
       col_lookup(9F)

				 Oct 13, 2008		    NET_GETLIFADDR(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net