NG_UI(4) BSD Kernel Interfaces Manual NG_UI(4)NAMEng_UI — UI netgraph node type
The UI node type has two hooks, upstream and downstream. Packets
received on downstream must have 0x03 (indicating unnumbered information)
as their first byte; if not the packet is dropped. This byte is then
stripped and the remainder of the packet sent out on upstream.
Conversely, packets received on upstream will have a 0x03 byte prepended
to them before being forwarded out on the downstream hook.
This node type supports the following hooks:
Downstream connection. Packets on this side of the node have a
0x03 as their first byte.
Upstream connection. Packets on this side of the node have the
initial 0x03 byte stripped off.
This node type supports only the generic control messages.
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
when both hooks have been disconnected.
SEE ALSOnetgraph(4), ngctl(8)HISTORY
The ng_UI node type was implemented in FreeBSD 4.0.
Julian Elischer ⟨julian@FreeBSD.org⟩
BSD January 19, 1999 BSD