NG_UBT(4) BSD Kernel Interfaces Manual NG_UBT(4)NAMEng_ubt — Netgraph node type that is also a driver for Bluetooth USB
The ubt node type is both a persistent Netgraph node type and a driver
for Bluetooth USB devices. It implements a Bluetooth USB transport layer
as per chapter H2 of the Bluetooth Specification Book v1.1. A new node
is created when a supported USB device is plugged in.
The node has a single hook called hook. Incoming bytes received on the
device are re-assembled into HCI frames (according to the length). Full
HCI frames are sent out on the hook. The node will add a HCI frame indi‐
cator if the device did not send it. HCI frames received on hook are
transmitted out. The node will drop the HCI frame indicator unless the
device requires it to be present.
The ng_ubt driver supports all Bluetooth USB devices that conform with
the Bluetooth specification v1.1, including:
· 3Com 3CREB96
· AIPTEK BR0R02
· EPoX BT-DG02
· Mitsumi Bluetooth USB adapter
· MSI MS-6967
· TDK Bluetooth USB adapter
This node type supports the following hooks:
hook single HCI frame contained in a single mbuf structure.
This node type supports the generic control messages, plus the following:
Returns an integer containing the current debug level for the
This command takes an integer argument and sets the current debug
level for the node.
This command takes a parameter that specifies the queue number
and returns the current maximal length of the queue for the node.
This command takes two parameters that specify the queue number
and the maximum length of the queue and sets the maximal length
of the queue for the node.
Returns various statistic information for the node, such as: num‐
ber of bytes (frames) sent, number of bytes (frames) received and
number of input (output) errors.
Reset all statistic counters to zero.
This node shuts down when the corresponding USB device is un-plugged.
SEE ALSOnetgraph(4), ugen(4), usb(4), ngctl(8)HISTORY
The ubt node type was implemented in FreeBSD 5.0.
Maksim Yevmenkin ⟨firstname.lastname@example.org⟩
Isochronous USB transfers are broken. This means that the USB device
will not be able to transfer SCO data (voice). USB interrupt transfers
are implemented as bulk-in transfers (not really a bug).
BSD September 13, 2004 BSD