pm_busy_component man page on SmartOS

Man page or keyword search:  
man Server   16655 pages
apropos Keyword Search (all sections)
Output format
SmartOS logo
[printable version]

PM_BUSY_COMPONENT(9F)					 PM_BUSY_COMPONENT(9F)

NAME
       pm_busy_component,  pm_idle_component - control device component avail‐
       ability for Power Management

SYNOPSIS
       #include <sys/ddi.h>
       #include <sys/sunddi.h>

       int pm_busy_component(dev_info_t *dip, int component);

       int pm_idle_component(dev_info_t *dip, int component);

INTERFACE LEVEL
       Solaris DDI specific (Solaris DDI)

PARAMETERS
       dip
		    Pointer to the device's dev_info structure.

       component
		    The number of the component to be power-managed.

DESCRIPTION
       The pm_busy_component() function sets component	of  dip	 to  be	 busy.
       Calls  to  pm_busy_component()  are  stacked, requiring a corresponding
       number of calls to  pm_idle_component()	to  make  the  component  idle
       again.	When a device is busy it will not be power-managed by the sys‐
       tem.

       The pm_idle_component() function marks component	 idle,	recording  the
       time  that  component  went idle. This function must be called once for
       each call to pm_busy_component(). A component which is idle  is	avail‐
       able  to	 be power-managed by the system. The pm_idle_component() func‐
       tion has no effect if the component is already idle, except  to	update
       the system's notion of when the device went idle.

       If  these  functions  are called as a result of entry into the driver's
       attach(9E), detach(9E) or power(9E) entry point, these  functions  must
       be  called from the same thread which entered attach(9E), detach(9E) or
       power(9E).

RETURN VALUES
       The pm_busy_component() and pm_idle_component() functions return:

       DDI_SUCCESS
		      Successfully set the indicated component busy or idle.

       DDI_FAILURE
		      Invalid component number component or the device has  no
		      components.

CONTEXT
       These  functions can be called from user or kernel context. These func‐
       tions may also be called from interrupt context, providing they are not
       the first Power Management function called by the driver.

ATTRIBUTES
       See attributes(5) for descriptions of the following attributes:

       ┌────────────────────┬─────────────────┐
       │  ATTRIBUTE TYPE    │ ATTRIBUTE VALUE │
       ├────────────────────┼─────────────────┤
       │Interface stability │ Committed	      │
       └────────────────────┴─────────────────┘

SEE ALSO
       power.conf(4),	  pm(7D),     attach(9E),    detach(9E),    power(9E),
       pm_raise_power(9F), pm(9P), pm-components(9P)

       Writing Device Drivers

				 Jul 21, 2004		 PM_BUSY_COMPONENT(9F)
[top]

List of man pages available for SmartOS

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net