REBOOT(8) BSD System Manager's Manual REBOOT(8)NAME
reboot, halt — stopping and restarting the system
The halt and reboot utilities flush the file system cache to disk, send
all running processes a SIGTERM (and subsequently a SIGKILL) and, respec‐
tively, halt or restart the system. The action is logged, including
entering a shutdown record into the wtmp(5) file.
The options are as follows:
-l The halt or reboot is not logged to the system log. This option
is intended for applications such as shutdown(8), that call
reboot or halt and log this themselves.
-n The file system cache is not flushed. This option should proba‐
bly not be used.
-q The system is halted or restarted quickly and ungracefully, and
only the flushing of the file system cache is performed (if the
-n option is not specified). This option should probably not be
Normally, the shutdown(8) utility is used when the system needs to be
halted or restarted, giving users advance warning of their impending doom
and cleanly terminating specific programs.
SEE ALSOwtmp(5), shutdown(8), sync(8)HISTORY
A reboot utility appeared in Version 6 AT&T UNIX.
BSD June 9, 1993 BSD