SAVECORE(8) OpenBSD System Manager's Manual SAVECORE(8)NAMEsavecore - save a core dump of the operating system
SYNOPSISsavecore [-cfvz] [-N system] directory
DESCRIPTIONsavecore copies the currently running kernel and its associated core dump
into directory, and enters a reboot message and information about the
core dump into the system log.
The options are as follows:
-c Clears the dump, so that future invocations of savecore will
-f Forces a dump to be taken even if the dump doesn't appear correct
or there is insufficient disk space.
Use system as the kernel instead of the default /bsd.
-v Prints out some additional debugging information.
-z Compresses the core dump and kernel (see compress(1)).
savecore checks the core dump in various ways to make sure that it is
current and that it corresponds to the currently running system. If it
passes these checks, it saves the core image in directory/bsd.#.core and
the system in directory/bsd.# (or in directory/bsd.#.core.Z and
directory/bsd.#.Z, respectively, if the -z option is used). The ``#'' is
the number from the first line of the file directory/bounds, and it is
incremented and stored back into the file each time savecore successfully
savecore also checks the available disk space before attempting to make
the copies. If there is insufficient disk space in the filesystem
containing directory, or if the file directory/minfree exists and the
number of free kilobytes (for non-superusers) in the filesystem after the
copies were made would be less than the number in the first line of this
file, the copies are not attempted.
If savecore successfully copies the kernel and the core dump, the core
dump is cleared so that future invocations of savecore will ignore it.
savecore is meant to be called near the end of the initialization file
/etc/rc (see rc(8)).
/bsd current kernel
SEE ALSOcompress(1), crash(8), syslogd(8)HISTORY
The savecore command appeared in 4.1BSD.
The minfree code does not consider the effect of compression.
OpenBSD 4.9 September 10, 2008 OpenBSD 4.9