SEM(4) BSD Kernel Interfaces Manual SEM(4)NAMEsem — POSIX semaphores
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The sem facility provides system calls used by the standard C library
(libc) to implement POSIX semaphores. This facility offers support for
such functions as sem_init() and sem_wait(). It is available both as a
kernel option for static inclusion and as a dynamic kernel module.
SEE ALSOsem_destroy(3), sem_getvalue(3), sem_init(3), sem_open(3), sem_post(3),
sem_wait(3), config(8), kldload(8), kldunload(8)HISTORY
The sem facility appeared as a kernel option in FreeBSD 3.0. The sem
kernel module appeared in FreeBSD 5.0.
BSD November 11, 2006 BSD