snp man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

SNP(4)			 BSD Kernel Interfaces Manual			SNP(4)

NAME
     snp — tty snoop interface

SYNOPSIS
     #include <sys/snoop.h>

     int
     ioctl(fd, SNPSTTY, &dev);

     int
     ioctl(fd, SNPGTTY, &dev);

     int
     ioctl(fd, FIONREAD, &result);

DESCRIPTION
     /dev/snp? are snoop devices which allow users to attach to any tty and
     watch activities on it.  The kernel must be compiled with device snp, or
     the snp module must be loaded, for these devices to be available.

     To associate a given snp device with a tty to be observed, open the snp
     device and then use the SNPSTTY ioctl.  The argument passed to the ioctl
     is the address of a variable of type dev_t.  To detach the snp device
     from a tty use a pointer to a value of (dev_t)-1.

     The SNPGTTY ioctl returns information about the current tty attached to
     the open snp device.

     The FIONREAD ioctl returns a positive value equal to the number of char‐
     acters in a read buffer.  Special values defined are:

     SNP_OFLOW	   device overflow occurred, device detached.

     SNP_TTYCLOSE  tty not attached.

     SNP_DETACH	   snp device has been detached by user or tty device has been
		   closed and detached.

SEE ALSO
     pty(4), sio(4), kldload(8), watch(8)

HISTORY
     The snp device first appeared in FreeBSD 2.1.

AUTHORS
     Ugen J.S. Antsilevich ⟨ugen@NetVision.net.il⟩

BUGS
     Caveat emptor!  This manual page is horribly stale and wildly inaccurate
     in some places.

     While in line mode, user input can't be seen.  No signals may be sent to
     the observed tty.

BSD			       February 24, 1995			   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net