UMODEM(4) BSD Kernel Interfaces Manual UMODEM(4)NAMEumodem — USB modem support
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The umodem driver provides support for USB modems in the Communication
Device Class using the Abstract Control Model. These modems are basi‐
cally standard serial line modems, but they are accessed via USB instead.
They support a regular AT command set. The commands can either be multi‐
plexed with the data stream or handled through separate pipes. In the
latter case the AT commands have to be given on a device separate from
the data device.
The device is accessed through the ucom(4) driver which makes it behave
like a tty(4).
Devices supported by the umodem driver include:
· 3Com 5605
· Curitel PC5740 Wireless Modem
· Kyocera AH-K3001V Mobile Phone(WILLCOM)
· Kyocera WX320K Mobile Phone(WILLCOM)
· Metricom Ricochet GS USB wireless modem
· Sierra MC5720 Wireless Modem
· Yamaha Broadband Wireless Router RTW65b
· ELSA MicroLink 56k USB modem
· Sony Ericsson W810i phone
SEE ALSOtty(4), ucom(4), usb(4)HISTORY
The umodem driver appeared in NetBSD 1.5. This manual page was adopted
from NetBSD by Tom Rhodes ⟨trhodes@FreeBSD.org⟩ in April 2002.
Only modems with multiplexed commands and data are supported at the
BSD November 22, 2006 BSD