vdrop man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VHOLD(9)		 BSD Kernel Developer's Manual		      VHOLD(9)

NAME
     vhold, vdrop, vdropl — acquire/release a hold on a vnode

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     void
     vhold(struct vnode *vp);

     void
     vholdl(struct vnode *vp);

     void
     vdrop(struct vnode *vp);

     void
     vdropl(struct vnode *vp);

DESCRIPTION
     The vhold() and vholdl() functions increment the v_holdcnt of the given
     vnode.  If the vnode has already been added to the free list and is still
     referenced, it will be removed.

     The vdrop() and vdropl() functions decrement the v_holdcnt of the vnode.
     If the holdcount is less than or equal to zero prior to calling vdrop()
     or vdropl(), the system will panic.  If the vnode is no longer refer‐
     enced, it will be freed.

     vhold() and vdrop() lock the vnode interlock while vholdl() and vdropl()
     expect the interlock to already be held.

SEE ALSO
     vnode(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 April 1, 2007				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net