vfs_getnewfsid man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VFS_GETNEWFSID(9)	 BSD Kernel Developer's Manual	     VFS_GETNEWFSID(9)

NAME
     vfs_getnewfsid — allocate a new file system identifier

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>

     void
     vfs_getnewfsid(struct mount *mp);

DESCRIPTION
     The vfs_getnewfsid() function allocates a new file system identifier for
     the mount point given.  File systems typically call vfs_getnewfsid() in
     their mount routine in order to acquire a unique ID within the system
     which can later be used to uniquely identify the file system via calls
     such as vfs_getvfs(9).

     The actual fsid is made up of two 32 bit integers, that are stored in the
     statfs structure of mp.  The first integer is unique in the set of
     mounted file systems, while the second holds the file system type.

     typedef struct fsid {
	     int32_t val[2];
     } fsid_t;

PSEUDOCODE
     xxx_mount(struct mount *mp, char *path, caddr_t data,
	     struct nameidata *ndp, struct thread *td)
     {
	     ...
	     vfs_getnewfsid(mp);
	     ...
     }

SEE ALSO
     vfs_getvfs(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD			       November 21, 2001			   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net