vfs_suser man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VFS_SUSER(9)		 BSD Kernel Developer's Manual		  VFS_SUSER(9)

NAME
     vfs_suser — check if credentials have superuser privileges for a mount
     point

SYNOPSIS
     #include <sys/param.h>
     #include <sys/systm.h>
     #include <sys/mount.h>

     int
     vfs_suser(struct mount *mp, struct thread *td);

DESCRIPTION
     The vfs_suser() function checks if the credentials given include supe‐
     ruser powers for the given mount point.  It will check to see if the
     thread passed in has the same credentials as the user that mounted the
     file system.  If so, it returns 0, otherwise it returns what
     priv_check(9) would have returned.

RETURN VALUES
     The vfs_suser() function returns 0 if the user has superuser powers and
     EPERM otherwise.  This is the reverse logic of some other implementations
     of suser() in which a TRUE response indicates superuser powers.

SEE ALSO
     chroot(2), jail(2)

HISTORY
     The vfs_suser() function was introduced in FreeBSD 5.2.

AUTHORS
     This manual page was written by Alfred Perlstein.

BSD				 April 2, 2004				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net