vgone man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VGONE(9)		 BSD Kernel Developer's Manual		      VGONE(9)

NAME
     vgone — prepare a vnode for reuse

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     void
     vgone(struct vnode *vp);

DESCRIPTION
     The vgone() function prepares the vnode to be destroyed.  The preparation
     includes the cleaning of all file system specific data and the removal
     from its mount point vnode list.

     If the vnode has a v_usecount of zero, and its VI_DOOMED flag is not set,
     it is moved to the head of the free list as in most cases the vnode is
     about to be reused, or its file system is being unmounted.

     The vgone() function takes an exclusively locked vnode, and returns with
     the vnode exclusively locked.

SEE ALSO
     vnode(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD			       November 12, 2010			   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net