vm_map_clean man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_MAP_CLEAN(9)		 BSD Kernel Developer's Manual	       VM_MAP_CLEAN(9)

NAME
     vm_map_clean — push dirty pages to their pager

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_map.h>

     int
     vm_map_clean(vm_map_t map, vm_offset_t start, vm_offset_t end,
	 boolean_t syncio, boolean_t invalidate);

DESCRIPTION
     The vm_map_clean() function forces any dirty cached pages in the range
     start to end within the map to be pushed to their underlying pager.

     If syncio is TRUE, dirty pages are written synchronously.

     If invalidate is TRUE, any cached pages are also freed.

     The range provided must be contiguous, it MUST NOT contain holes.	The
     range provided MUST NOT contain any sub-map entries.

IMPLEMENTATION NOTES
     This routine holds the Giant lock to prevent multiple entry.

RETURN VALUES
     The vm_map_clean() function returns KERN_SUCCESS if successful.

     Otherwise, KERN_INVALID_ADDRESS will be returned if the function encoun‐
     tered a sub-map entry; KERN_INVALID_ARGUMENT will be returned if the
     function encountered a hole in the region provided, or if an entry could
     not be found for the given start address.

SEE ALSO
     vm_map(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 19, 2003				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net