vm_map_inherit man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_MAP_INHERIT(9)	 BSD Kernel Developer's Manual	     VM_MAP_INHERIT(9)

NAME
     vm_map_inherit — set fork inheritance flags for a range within a map

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_map.h>

     int
     vm_map_inherit(vm_map_t map, vm_offset_t start, vm_offset_t end,
	 vm_inherit_t new_inheritance);

DESCRIPTION
     The vm_map_inherit() function sets the inheritance flags for the range
     start to end within the target map to the value new_inheritance.

     The new_inheritance flag must have one of the values VM_INHERIT_NONE,
     VM_INHERIT_COPY, or VM_INHERIT_SHARE.  This affects how the map will be
     shared with child maps when the associated process forks.

IMPLEMENTATION NOTES
     The vm_map_inherit() function obtains a lock on the map using
     vm_map_lock(9) for the duration of the function.

RETURN VALUES
     The vm_map_inherit() function returns KERN_SUCCESS if the inheritance
     flags could be set.  Otherwise, if the provided flags were invalid,
     KERN_INVALID_ARGUMENT will be returned.

SEE ALSO
     fork(2)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 19, 2003				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net