vm_map_simplify_entry man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_MAP_SIMPLIFY_ENTRY(9) BSD Kernel Developer's ManualVM_MAP_SIMPLIFY_ENTRY(9)

NAME
     vm_map_simplify_entry — simplify a vm_map_entry

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_map.h>

     void
     vm_map_simplify_entry(vm_map_t map, vm_map_entry_t entry);

DESCRIPTION
     The vm_map_simplify_entry() function simplifies the given entry by merg‐
     ing with either neighbour.	 The map must be locked upon entry.

     This function also has the ability to merge with both neighbours.

     This function guarantees that the passed entry remains valid, although
     possibly extended.

SEE ALSO
     vm_map(9), vm_map_insert(9), vm_map_remove(9)

AUTHORS
     This manual page was written by Bruce M Simpson ⟨bms@spc.org⟩.

BSD				 July 19, 2003				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net