vm_page_io man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_PAGE_IO_START(9)	 BSD Kernel Developer's Manual	   VM_PAGE_IO_START(9)

NAME
     vm_page_io_start, vm_page_io_finish — ready or unready a page for I/O

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_io_start(vm_page_t m);

     void
     vm_page_io_finish(vm_page_t m);

DESCRIPTION
     The vm_page_io_start() function prepares the page for I/O by incrementing
     its busy flag by one.

     The vm_page_io_finish() function lowers the busy count on the page by
     one, if the resulting busy count is zero, a wakeup(9) will be issued if
     the page has been marked VPO_WANTED.  A page is typically marked
     VPO_WANTED by a thread to register its interest in the page to either
     complete I/O or becoming available for general use.

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩ and Alfred
     Perlstein ⟨alfred@FreeBSD.org⟩.

BSD				 July 17, 2001				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net