vm_page_protect man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_PAGE_PROTECT(9)	 BSD Kernel Developer's Manual	    VM_PAGE_PROTECT(9)

NAME
     vm_page_protect — lower a page's protection

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_protect(vm_page_t mem, int prot);

DESCRIPTION
     The vm_page_protect() function lowers a page's protection.	 The protec‐
     tion is never raised by this function; therefore, if the page is already
     at VM_PROT_NONE, the function does nothing.

     Its arguments are:

     mem   The page whose protection is lowered.

     prot  The protection the page should be reduced to.  If VM_PROT_NONE is
	   specified, then the PG_WRITABLE and PG_MAPPED flags are cleared and
	   the pmap_page's protection is set to VM_PROT_NONE.  If VM_PROT_READ
	   is specified, then the PG_WRITABLE flag is cleared and the
	   pmap_page's protection is set to VM_PROT_READ.

     Higher protection requests are ignored.

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 14, 2001				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net