vm_page_rename man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VM_PAGE_RENAME(9)	 BSD Kernel Developer's Manual	     VM_PAGE_RENAME(9)

NAME
     vm_page_rename — move a page

SYNOPSIS
     #include <sys/param.h>
     #include <vm/vm.h>
     #include <vm/vm_page.h>

     void
     vm_page_rename(vm_page_t m, vm_object_t new_object,
	 vm_pindex_t new_pindex);

DESCRIPTION
     The vm_page_rename() function removes a page from one object, and adds it
     to another at the given page index.  The page is added to the given
     object, and is removed from the object that is currently associated with.
     If the page is currently on the cache queue it will be deactivated unless
     it is wired or unmanaged, in which case the deactivation will fail.  The
     entire page is marked as dirty after the move.

     The arguments to vm_page_rename() are:

     m		 The page to move.

     new_object	 The object the page should be inserted into.

     new_pindex	 The page index into new_object at which the new page should
		 be inserted.

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 17, 2001				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net