vn_isdisk man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VN_ISDISK(9)		 BSD Kernel Developer's Manual		  VN_ISDISK(9)

NAME
     vn_isdisk — checks if a vnode represents a disk

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     vn_isdisk(struct vnode *vp, int *errp);

DESCRIPTION
     The vn_isdisk() function checks to see if vp represents a disk.  In order
     for vp to be a disk, it must be a character device, v_rdev must be valid,
     and the cdevsw entry's flags must have D_DISK set.

     Its arguments are:

     vp	   The vnode to check.

     errp  An integer pointer to store the error number in if the call fails.

RETURN VALUES
     If the vnode represents a disk, 1 is returned; otherwise, 0 is returned
     and errp will contain the error number.

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 July 9, 2001				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net