MODULE_DEPEND man page on DragonFly

Man page or keyword search:  
man Server   44335 pages
apropos Keyword Search (all sections)
Output format
DragonFly logo
[printable version]

MODULE_DEPEND(9)	 BSD Kernel Developer's Manual	      MODULE_DEPEND(9)

NAME
     MODULE_DEPEND — set kernel module dependencies

SYNOPSIS
     #include <sys/module.h>

     MODULE_DEPEND(name, moddepend, int minversion, int prefversion,
	 int maxversion);

DESCRIPTION
     The MODULE_DEPEND() macro sets a dependency of the module called name on
     another kernel module moddepend, which has registered its version with
     MODULE_VERSION().	Three versions must be specified on which the module
     can depend: The minimal and maximal versions this module can depend on as
     well as the preferred version.

EXAMPLES
     MODULE_DEPEND(foo, bar, 1, 3, 4);

SEE ALSO
     DECLARE_MODULE(9), module(9), MODULE_VERSION(9)

AUTHORS
     This manual page was written by Alexander Langer ⟨alex@FreeBSD.org⟩.

BSD				 July 19, 2006				   BSD
[top]

List of man pages available for DragonFly

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net