VFS_SET man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VFS_SET(9)		 BSD Kernel Developer's Manual		    VFS_SET(9)

NAME
     VFS_SET — set up loadable file system vfsconf

SYNOPSIS
     #include <sys/param.h>
     #include <sys/kernel.h>
     #include <sys/module.h>
     #include <sys/mount.h>

     void
     VFS_SET(struct vfsops *vfsops, fsname, int flags);

DESCRIPTION
     VFS_SET() creates a vfsconf structure for the loadable module with the
     given vfsops, fsname and flags, and declares it by calling
     DECLARE_MODULE(9) using vfs_modevent() as the event handler.

     Possible values for the flags argument are:

     VFCF_STATIC      File system should be statically available in the ker‐
		      nel.

     VFCF_NETWORK     Network exportable file system.

     VFCF_READONLY    Does not support write operations.

     VFCF_SYNTHETIC   Pseudo file system, data does not represent on-disk
		      files.

     VFCF_LOOPBACK    Loopback file system layer.

     VFCF_UNICODE     File names are stored as Unicode.

     VFCF_JAIL	      Can be mounted from within a jail if
		      security.jail.mount_allowed sysctl is set to 1.

     VFCF_DELEGADMIN  Supports delegated administration if vfs.usermount
		      sysctl is set to 1.

PSEUDOCODE
     /*
      * fill in the ones we use, and use the vfs_std for the rest.
      */
     static struct vfsops myfs_vfsops = {
	     myfs_mount,
	     vfs_stdstart,
	     myfs_unmount,
	     myfs_root,
	     vfs_stdquotactl,
	     myfs_statfs,
	     vfs_stdsync,
	     vfs_stdvget,
	     vfs_stdfhtovp,
	     vfs_stdcheckexp,
	     vfs_stdvptofh,
	     vfs_stdinit,
	     vfs_stduninit,
	     vfs_stdextattrctl,
     };

     VFS_SET(myfs_vfsops, skelfs, 0);

SEE ALSO
     jail(2), jail(8), DECLARE_MODULE(9), vfsconf(9), vfs_modevent(9)

AUTHORS
     This manual page was written by Chad David ⟨davidc@acns.ab.ca⟩.

BSD				 April 5, 2007				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net