VFS_UNMOUNT man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VFS_UNMOUNT(9)		 BSD Kernel Developer's Manual		VFS_UNMOUNT(9)

NAME
     VFS_UNMOUNT — unmount a file system

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>
     #include <sys/vnode.h>

     int
     VFS_UNMOUNT(struct mount *mp, int mntflags);

DESCRIPTION
     The VFS_UNMOUNT() macro unmounts a file system.

     The arguments it expects are:

     mp	       The file system.

     mntflags  Bit-mask of flags for the unmount operation.  The flags cur‐
	       rently supported by VFS_UNMOUNT() are:

	       MNT_FORCE  Open files are forcibly closed before the file sys‐
			  tem is unmounted.

SEE ALSO
     vflush(9), VFS(9), vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 May 23, 2009				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net