VFS_VGET man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VFS_VGET(9)		 BSD Kernel Developer's Manual		   VFS_VGET(9)

NAME
     VFS_VGET — convert an inode number to a vnode

SYNOPSIS
     #include <sys/param.h>
     #include <sys/mount.h>
     #include <sys/vnode.h>

     int
     VFS_VGET(struct mount *mp, ino_t ino, int flags, struct vnode **vpp);

DESCRIPTION
     The VFS_VGET() looks up or creates a vnode from a (mount, inode#) tupple.

     Its arguments are:

     mp	    The mount point.

     ino    The inode representing the file.  This is a unique number assigned
	    by the file system when vnodes are first created.

     flags  Additional locking flags to pass through to vget(9).

     vpp    Return parameter for the vnode.

     This is an optional file system entry-point for file systems mainly
     intended for NFS server use, but many file systems use it internally in
     VOP_LOOKUP(9) and similar.

     If the file system does not support this call, then it should return
     EOPNOTSUPP.

     Please see ffs_vget() in sys/ufs/ffs/ffs_vfsops.c for the canonical exam‐
     ple.

SEE ALSO
     VFS(9), vget(9), vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				January 7, 2005				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net