VOP_CREATEVOBJECT man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VOP_CREATEVOBJECT(9)	 BSD Kernel Developer's Manual	  VOP_CREATEVOBJECT(9)

NAME
     VOP_CREATEVOBJECT, VOP_DESTROYVOBJECT, VOP_GETVOBJECT — VM object inter‐
     action

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     VOP_CREATEVOBJECT(struct vnode *vp, struct ucred *cred,
	 struct thread *td);

     int
     VOP_DESTROYVOBJECT(struct vnode *vp);

     int
     VOP_GETVOBJECT(struct vnode *vp, struct vm_object **objpp);

DESCRIPTION
     These calls are used to control the association of a VM object with a
     particular vnode.

     The arguments specific to these functions are:

     vp	    The vnode of the file.

     objpp  The VM object being returned, or NULL if the caller wants to test
	    for the existence of the VM object).

     VFS(9) invokes VOP_CREATEVOBJECT() when it needs to create a VM object
     for the given vnode(9).  File system code may pass this call down to the
     underlying file system.  This VOP can be called multiple times, and file
     system code should ignore any additional calls, exiting with a zero
     return code.

     VOP_DESTROYVOBJECT() is called when a vnode(9) is recycled.

     VOP_GETVOBJECT() should be used by all kernel code to get a VM object.
     The returned VM object may belong to a different file system in the case
     of stacked mounts.

     VFS(9) has three functions which perform standard operations by creating
     and destroying VM objects.	 These functions are: vop_stdcreatevobject(),
     vop_stddestroyvobject() and vop_stdgetvobject().

     Note: a vnode(9) should be locked on entry and must be left locked on
     exit.

RETURN VALUES
     The VOP_CREATEVOBJECT(), VOP_DESTROYVOBJECT() and VOP_GETVOBJECT() func‐
     tions return zero on success, or a non-zero value on failure.  Zero is
     returned on success, otherwise an error is returned.

EXAMPLES
     By default, file systems leave VM object handling to the vop_std*() func‐
     tions.

SEE ALSO
     vnode(9), VOP_GETPAGES(9), VOP_PUTPAGES(9)

AUTHORS
     This manual page was written by Boris Popov.

BSD			      September 10, 2000			   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net