VOP_PATHCONF man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VOP_PATHCONF(9)		 BSD Kernel Developer's Manual	       VOP_PATHCONF(9)

NAME
     VOP_PATHCONF — return POSIX pathconf information

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>
     #include <sys/unistd.h>

     int
     VOP_PATHCONF(struct vnode *vp, int name, int *retval);

DESCRIPTION
     The arguments are:

     vp	     The vnode to get information about.

     name    The type of information to return.

     retval  The place to return the information.

     The value of name specifies what should be returned:

     _PC_LINK_MAX	   The maximum number of links to a file.

     _PC_NAME_MAX	   The maximum number of bytes in a file name.

     _PC_PATH_MAX	   The maximum number of bytes in a pathname.

     _PC_PIPE_BUF	   The maximum number of bytes which will be written
			   atomically to a pipe.

     _PC_CHOWN_RESTRICTED  Return 1 if appropriate privileges are required for
			   the chown(2) system call, otherwise 0.

     _PC_NO_TRUNC	   Return 1 if file names longer than KERN_NAME_MAX
			   are truncated.

RETURN VALUES
     If name is recognized, *retval is set to the specified value and zero is
     returned, otherwise EINVAL is returned.

SEE ALSO
     pathconf(2), vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net