VOP_READLINK man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VOP_READLINK(9)		 BSD Kernel Developer's Manual	       VOP_READLINK(9)

NAME
     VOP_READLINK — read the target of a symbolic link

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>
     #include <sys/uio.h>

     int
     VOP_READLINK(struct vnode *vp, struct uio *uio, struct ucred *cred);

DESCRIPTION
     This reads the target pathname of a symbolic link

     vp	  The vnode of the symlink.

     uio  The location of the data to be read or written.

     cred
	  The credentials of the caller.

LOCKS
     The vnode should be locked on entry and will still be locked on exit.

RETURN VALUES
     Zero is returned on success, otherwise an error code is returned.

ERRORS
     [EIO]		A read error occurred while reading the contents of
			the symlink.

SEE ALSO
     uiomove(9), vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD				 July 24, 1996				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net