VOP_VPTOCNP man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VOP_VPTOCNP(9)		 BSD Kernel Developer's Manual		VOP_VPTOCNP(9)

NAME
     VOP_VPTOCNP — translate a vnode to its component name

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     VOP_VPTOCNP(struct vnode *vp, struct vnode **dvp, char *buf,
	 int *buflen);

DESCRIPTION
     This translates a vnode into its component name, and writes that name to
     the head of the buffer specified by buf

     vp	     The vnode to translate.

     dvp     The vnode of the parent directory of vp.

     buf     The buffer into which to preprend the component name.

     buflen  The remaining size of the buffer.

     The default implementation of VOP_VPTOCNP scans through vp's parent
     directory looking for a dirent with a matching file number.  If vp is not
     a directory, then VOP_VPTOCNP returns ENOENT.

LOCKS
     The vnode should be locked on entry and will still be locked on exit.
     The parent directory vnode will be unlocked on a successful exit.	How‐
     ever, it will have its hold count incremented.

RETURN VALUES
     Zero is returned on success, otherwise an error code is returned.

ERRORS
     [ENOMEM]		The buffer was not large enough to hold the vnode's
			component name.

     [ENOENT]		The vnode was not found on the file system.

SEE ALSO
     VOP_LOOKUP(9), vnode(9)

NOTES
     This interface is a work in progress.

HISTORY
     The function VOP_VPTOCNP appeared in FreeBSD 8.0.

AUTHORS
     This manual page was written by Joe Marcus Clarke.

BSD			       December 7, 2008				   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net