VOP_VPTOFH man page on FreeBSD

Man page or keyword search:  
man Server   9747 pages
apropos Keyword Search (all sections)
Output format
FreeBSD logo
[printable version]

VOP_VPTOFH(9)		 BSD Kernel Developer's Manual		 VOP_VPTOFH(9)

NAME
     VOP_VPTOFH — turn a vnode into an NFS filehandle

SYNOPSIS
     #include <sys/param.h>
     #include <sys/vnode.h>

     int
     VOP_VPTOFH(struct vnode *vp, struct fid *fhp);

DESCRIPTION
     This is used by the NFS server to create an opaque filehandle which
     uniquely identifies the file and which can be used by an NFS client to
     access the file in the future.

     Its arguments are:

     vp	  The vnode to make a filehandle for.

     fhp  Return parameter for the filehandle.

SEE ALSO
     VFS(9), VFS_FHTOVP(9), vnode(9)

AUTHORS
     This manual page was written by Doug Rabson.

BSD			       February 16, 2007			   BSD
[top]

List of man pages available for FreeBSD

Copyright (c) for man pages and the logo by the respective OS vendor.

For those who want to learn more, the polarhome community provides shell access and support.

[legal] [privacy] [GNU] [policy] [cookies] [netiquette] [sponsors] [FAQ]
Tweet
Polarhome, production since 1999.
Member of Polarhome portal.
Based on Fawad Halim's script.
....................................................................
Vote for polarhome
Free Shell Accounts :: the biggest list on the net