RANDOM(4) OpenBSD Programmer's Manual RANDOM(4)NAME
random, arandom - random data source devices
The various random devices produce high quality random output data.
Entropy data is collected from system activity (like disk, network, and
clock device interrupts and such), and then run through various hash or
message digest functions to generate the output. All the random devices
are expected to provide high quality pseudo-random output data.
The arc4random(3) function in userland libraries seeds itself from this
device (or with the sysctl(3) interface), providing a second level of
ARC4 hashed data without the need to access these devices every time.
SEE ALSOarc4random(3), md5(3), random(3), amdpm(4), glxsb(4), pchb(4),
A random device first appeared in the Linux operating system. This is a
ARC4 routines added by David Mazieres.
No randomness testing suite provided.
OpenBSD 4.9 January 11, 2011 OpenBSD 4.9