AUDIOCE(4) OpenBSD Programmer's Manual (SPARC64) AUDIOCE(4)NAMEaudioce - SPARC64 EBus CS4231 audio device
audioce* at ebus?
audio* at audioce?
The audioce device uses the Crystal Semiconductor CS4231A Parallel
Interface, Multimedia Audio Codec chip to implement the audio device
interface described in audio(4). This device is found onboard on some
PCI/EBus based sparc64 models.
The audioce has a maximum precision of 16 bits and has both stereo and
The mixer(4) interface for audioce provides the following controls:
outputs.dac Specifies the attenuation of DAC output. A value
of `255' represents 0 dB attenuation.
outputs.dac.mute Specifies whether DAC output is muted.
outputs.output Specifies the set of enabled output ports. The
output ports are: `line', the line output jack,
`hp', the low impedance headphone jack, and `spkr',
the internal speaker. Note: Not all systems
support disabling the headphone and line output
inputs.cd Specifies the gain applied to CD audio input. A
value of `191' represents 0 dB.
inputs.cd.mute Specifies whether CD audio input is muted.
inputs.line Specifies the gain applied to line input. A value
of `191' represents 0 dB.
inputs.line.mute Specifies whether line input is muted.
outputs.monitor Specifies the attenuation of ADC to DAC output. A
value of `255' represents 0 dB.
outputs.monitor.mute Specifies whether ADC to DAC output is muted.
record.volume Specifies ADC input gain. A value of `0'
represents 0 dB.
record.source Specifies the active input port for the ADC. The
following are valid ADC input ports: `line', line
input, `cd', CD input, `mic', microphone input, and
`mixerout', post-mixer output as heard on the
record.mic_preamp Specifies whether an additional +20 dB gain is
applied to the ADC's microphone input.
SEE ALSOioctl(2), audio(4), ebus(4), intro(4)HISTORY
OpenBSD support for audioce first appeared in OpenBSD 3.0.
OpenBSD 4.9 July 26, 2010 OpenBSD 4.9