INTRO(4) OpenBSD Programmer's Manual (Zaurus) INTRO(4)NAMEintro - introduction to special files and hardware support
The manual pages in section 4 describe the special files, related driver
functions, and networking support available in the system. In this part
of the manual, the SYNOPSIS section of each configurable device gives a
sample specification for use in constructing a system description for the
config(8) program. The DIAGNOSTICS section lists messages which may
appear on the console and/or in the system error log /var/log/messages
due to errors in device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the
system and network related information. The networking support is
introduced in netintro(4).
This section describes the hardware supported on the zaurus platform.
Software support for these devices comes in two forms. A hardware device
may be supported with a character or block device driver, or it may be
used within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at
autoconfiguration time it is not accessible at any time afterwards. To
enable a device which did not autoconfigure, the system will have to be
The autoconfiguration system is described in autoconf(4). A list of the
supported devices is given below.
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Pseudo-devices are not listed. Not all supported devices are listed.
apm(4) advanced power management device interface
cd(4) ATAPI and SCSI CD-ROM driver
com(4) serial communications interface
lcd(4) Zaurus LCD display
pxadmac(4) PXA2x0 DMA controller
pxagpio(4) PXA2x0 GPIO interface
pxaintc(4) PXA2x0 interrupt controller
pxaip(4) PXA2x0 Integrated Peripheral Bus
pxammc(4) MMC/SD/SDIO controller
pxaost(4) PXA2x0 OS timer
pxapcic(4) PXA2x0 PCMCIA interface
pxaudc(4) PXA27x USB device controller
scoop(4) Compact Flash and GPIO controller
sd(4) SCSI disk driver
wd(4) WD100x compatible hard disk driver
wdc(4) WD100x compatible hard disk controller driver
zaudio(4) Zaurus audio device
zkbd(4) Zaurus keyboard support
zrc(4) Zaurus remote control support
zssp(4) SSP for inter-chip communication
zts(4) Zaurus touchscreen support
A further list of available devices is contained within the pages
describing the system buses and controllers. For example, a PCMCIA
device would be listed in the pcmcia(4) man page. The following buses
and controllers list these devices:
onewire(4) 1-Wire bus
pcmcia(4) introduction to PCMCIA (PC Card) support
usb(4) introduction to Universal Serial Bus support
SEE ALSOautoconf(4), config(8)HISTORY
The zaurus intro first appeared in OpenBSD 3.7.
OpenBSD 4.9 October 9, 2007 OpenBSD 4.9