PNINEK(4) OpenBSD Programmer's Manual (SPARC) PNINEK(4)NAME
pninek - Weitek Power9000 accelerated frame buffer
btcham0 at obio?
pninek0 at sbus?
wsdisplay* at pninek?
The pninek is a color frame buffer with graphics acceleration, embedded
in the Tadpole SPARCbook 3 laptop. It is based on the Weitek Power9000
video processor and a Brooktree Bt445 `Chameleon' RAMDAC.
Due to specifics of the video hardware on the Tadpole SPARCbook 3, the
complete driver is split in two parts:
btcham RAMDAC interface
pninek Video controller interface
The combination of both btcham and pninek drivers interfaces the frame
buffer with the wscons(4) console framework. They do not provide direct
device driver entry points but make their function available via the
internal wsdisplay(4) interface.
If the tctrl(4) device is also configured, the pninek will be powered
down when the lid of the laptop is closed or the screen is blanked.
SEE ALSOintro(4), sbus(4), wscons(4), wsdisplay(4)BUGS
There is currently no way to switch back and forth from the onboard
display to the external connector.
It is not possible to change display resolution.
Acceleration code does not work correctly, and is therefore disabled.
OpenBSD 4.9 March 31, 2008 OpenBSD 4.9