CGTHREE(4) OpenBSD Programmer's Manual (SPARC64) CGTHREE(4)NAMEcgthree - 8-bit color frame buffer
cgthree* at sbus?
wsdisplay* at cgthree?
The cgthree is an SBus color frame buffer.
The cgthree driver interfaces the frame buffer with the wscons(4) console
framework. It does not provide direct device driver entry points but
makes its functions available via the internal wsdisplay(4) interface.
If the cgthree frame buffer is used as the console display, it is
possible, for some models, to select a different resolution than the
default 1152x900 or 1024x768 by changing the OpenPROM environment. To
change the default resolution, type the following:
ok setenv output-device screen:r1152x900x66
to change to a 66Hz 1152x900 resolution.
If the cgthree frame buffer is a secondary display, or a serial console
is used, the display resolution can not be changed without using an
nvramrc OpenPROM script. Refer to the Sun Frame Buffer FAQ for details.
The cgthree frame buffer accepts the following resolutions:
screen:r1024x768x77 Super VGA 1024x768, with a refresh rate of 77Hz.
This is the default setting on model 501-2691.
screen:r1152x900x66 Standard 1152x900, with a refresh rate of 66Hz.
This is the default setting on older models (501-
1415 and 501-8044).
screen:r1152x900x76 Standard 1152x900, with a refresh rate of 76Hz.
This is the default setting on more recent models
(501-1718 and 501-1909).
Note that not all models support settings other than their default
SEE ALSOintro(4), sbus(4), wscons(4), wsdisplay(4)
Sun Frame Buffer FAQ, http://www.sunhelp.org/faq/FrameBuffer.html.
OpenBSD 4.9 March 31, 2008 OpenBSD 4.9