DE(4) BSD Kernel Interfaces Manual DE(4)NAMEde — DEC DC21x4x Ethernet device driver
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The de driver provides support for the Ethernet adapters based on the
Digital Equipment DC21x4x based self-contained Ethernet and Fast Ethernet
The de driver supports the following media types:
autoselect Enable autoselection of the media type and options
10baseT/UTP Set 10Mbps operation on the 10baseT port
10base2/BNC Set 10Mbps operation on the BNC port
10base5/AUI Set 10Mbps operation on the AUI port
100baseTX Set 100Mbps (Fast Ethernet) operation
100baseFX Set 100Mbps operation
100baseT4 Set 100Mbps operation (4-pair cat-3 cable)
The de driver supports the following media options:
full-duplex Set full duplex operation
Note that the media types available depend on the particular card in use.
Some cards are explicitly programmed to a particular media type by a set‐
up utility and are not changeable.
Use the ifconfig(8) command and in particular the -m flag to list the
supported media types for your particular card.
The old “ifconfig linkN” method of configuration is not supported.
Adapters supported by the de driver include:
· Adaptec ANA-6944/TX
· Cogent EM100FX and EM440TX
· Corega FastEther PCI-TX
· D-Link DFE-500TX
· DEC DE435, DEC DE450, and DEC DE500
· ELECOM LD-PCI2T, LD-PCITS
· I-O DATA LA2/T-PCI
· SMC Etherpower 8432, 9332 and 9334
· ZNYX ZX3xx
de%d: waking device from sleep/snooze mode The 21041 and 21140A chips
support suspending the operation of the card.
de%d: error: desired IRQ of %d does not match device's actual IRQ of %d
The device probe detected that the board is configured for a different
interrupt than the one specified in the kernel configuration file.
de%d: not configured; limit of %d reached or exceeded There is a limit
of 32 de devices allowed in a single machine.
de%d: not configured; 21040 pass 2.0 required (%d.%d found)
de%d: not configured; 21140 pass 1.1 required (%d.%d found) Certain
revisions of the chipset are not supported by this driver.
SEE ALSOaltq(4), arp(4), netintro(4), ng_ether(4), ifconfig(8)AUTHORS
The de device driver was written by Matt Thomas. This manual page was
written by David E. O'Brien.
BSD July 16, 2005 BSD