default_disk_ir(5)default_disk_ir(5)NAMEdefault_disk_ir - enable and disable use of device's write cache in the
SCSI subsystem (OBSOLETE)
Note: This tunable is obsolete. HP no longer allows enabling, by
default, write cache for all direct access devices on the system. It
is still possible to enable write cache for a specific device through
the command. See scsictl(1M).
This tunable enables (1) or disables (0) the Immediate Reporting behav‐
ior of the SCSI subsystem, also known as Write Cache Enable (WCE).
With Immediate Reporting enabled, disk drives that have data caches
return from a system call, including raw writes, when the data is
cached, rather than returning after the data is written to the media.
This sometimes improves write performance especially for sequential
Cached data can be lost if a device power failure or reset occurs
before the device writes the cached data to media. Because of these
risks, the recommended value for this parameter on servers is Immediate
Reporting disabled (0).
Although not an option to the mount command, this tunable has a pro‐
found effect upon filesystem and raw disk performance and, conversely,
data integrity when system resets occur. This tunable also affects
delayed-write versus write-through-filesystem behavior.
Who Is Expected to Change This Tunable?
Restrictions on Changing
Changes to this tunable will take effect when the device is first
When Should the Tunable Be Turned On?
When a third party application vendor recommends it. For normal use,
HP strongly recommends you don't enable this tunable.
What Are the Side Effects of Turning the Tunable On?
Since enabling this tunable circumvents the protections provided by LVM
or RAID, there is a strong risk of filesystem corruption and data loss
in case of a device power failure or reset.
When Should the Tunable Be Turned Off?
HP recommends you always disable this tunable. This is especially true
if you don't want to take the risk of filesystem corruption and data
loss in case of a device power failure or reset.
What Are the Side Effects of Turning the Tunable Off?
This might reduce the performance of disk write (not read) access while
eliminating the risk of filesystem corruption and data loss in case of
a device power failure or reset.
What Other Tunables Should Be Changed at the Same Time?
All HP-UX kernel tunable parameters are release specific. This parame‐
ter has been obsoleted for HP-UX 11i Version 3.
Installation of optional kernel software, from HP or other vendors, may
cause changes to tunable parameter values. After installation, some
tunable parameters may no longer be at the default or recommended val‐
ues. For information about the effects of installation on tunable val‐
ues, consult the documentation for the kernel software being installed.
For information about optional kernel software that was factory
installed on your system, see at
was developed by HP.
SEE ALSOwrite(2), scsi(7).
OBSOLETE Kernel Tunable Parameter default_disk_ir(5)